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Tabeller 
Tabeller på web brukes som tabeller (slik de er ment å brukes!) og også som layout-verktøy 
for bilder og tekst som plasseres i tabellceller med rutenettet avslått. Vi kan slå sammen og 
splitte celler og sette tabeller inn i andre tabellers celler. 
 

Sett inn tabell: 
• Klikk tabell i Insert menyen eller fra menylinjen eller Insert > Table 

 

 
 
 
Vi kan select (merke) hele tabeller, én eller flere celler, rader og kolonner og så sette 
egenskaper for merkede områder. 
 

Merke en tabell gjøres på følgende måter: 
 
• Klikk i topp venstre hjørne eller klikk hvor som helst på høyre kant eller underkant av 

tabellen  
• Klikk én gang i tabellen og velg Modify > Table > Select Table  
• Klikk på tag-velger <table>  

 

Merke rader, kolonner eller celler 
 

• Plasser innsettingspunkt (musepeker) i venstre marg eller på toppen av en kolonne. 
Klikk når musepekeren forandrer seg til en sort pil 

• Klikk i en celle og dra med venstre musetast over rader og kolonner 
• Klikk i en celle, hold Ctrl nede og klikk i andre celler for å merke celler som ikke 

ligger ved siden av hverandre 
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Tabeller inni tabeller: 
• Stå i en celle: Insert > Table på vanlig måte 

 

 
 

Tabellegenskaper 
Property inspector viser tabell-egenskaper når en tabell er merket (selected) 
 

 
 

 Sett et navn på tabellen i Table Id feltet 
 Spesifiser antall rader og kolonner (Rows / Cols) 
 Størrelsen på tabellen settes i W(idth) og H(eight) i prosent av skjermens størrelse 

eller i antall pixler (W). Det er ikke så vanlig å spesifisere høyde 
 Celle utfyling (CellPad) cellevegger (CellSpace) kantelinjer (Border) settes.  

Ofte settes alle verdier til 0 når tabeller brukes til layout 
 Det er knappevalg for å fjerne eller forandre verdier man har satt for 

tabellen  
 
Valg for utseende på tabell gjort i Properties validere med xhtml Transitional, men vi bør 
venne oss til å bruke CSS med eksternt eller embedded stilark! 
 

Expanded Table Mode 
Når vi bruker tabeller til sideutlegg, så er det vanlig å sette både cellspacing, cellpadding og 
borders til 0. Det kan gjøre det vanskelig å få plassert musepekeren i en tom celle f eks, eller i 
det hele tatt å få en oversikt over tabellstrukturen særlig hvis det er tabeller inni tabeller.  
 
Klikk Expanded knappen, Layout fanen på Insert verktøylinjen. Dreamweaver setter inn 
kanter og cellpadding slik at du får oversikten. Html tabellkoden forandres ikke. Klikk 
Standard knappen, Layout fanen på Insert verktøylinjen når du har satt inn informasjon. 
 
View > Table Mode > Expanded Tables Mode (Alt+F6) 
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Tabellariske data 

Tabeller som tabeller med strukturert informasjon i celler og rader. Det er det tabeller egentlig 
skal brukes til, i nettdesign også! 

Importere eller kopiere Excel-filer 
Word- og Excel-filer kan importeres direkte inn i Windows-versjonen av Dreamweaver. 
 

1. Plasser musepekeren i dokumentet du vil importere til og velg 
File > Import > Excel Document (eller Word Document)  

2. I Open file dialogboksen, finn og dobbeltklikk dokumentet du vil importere  
3. Du får en organisert tabell med data - ingen formatering  
4. Edit > Paste (Ctrl+V) kopierer Excel data uten formatering  
5. Edit > Paste Special (Ctrl+Shift+V), > velg Full Formatting > OK for å beholde 

formatering. Det blir ikke CSS formatering!  

Importere data til en tabell 
Data i delimited format kan importeres til en html-tabell i Dreamweaver. Excel, Access og 
andre programmer kan lagre filer i delimited format enten med File > Export eller File > Save 
As. I Dreamweaver: 
 

1. File > Import > Tabular Data  
2. Klikk Browse og finn og åpne delimited filen  
3. Velg skilletegnet brukt som delimiter, tab, komma, kolon eller noe annet  
4. Sett tabellbredde (eller "Fit to data"), cellpadding, cellspacing, border og formater 

eventuelt kolonneoverskrifter  
5. Klikk OK for å importere data og lage tabellen  

 
 

Sortere data i en tabell 
Tabellkolonner kan sorteres i to nivåer, først etter ett kriterium, og så etter ett til. Mange 
muligheter som gjør det enkelt å presentere en liste over ansatte, en salgsrapport etc. på en 
ryddig måte. 
 

1. Commands > Sort Table og fyll ut dialogboksen: 
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Sort header rows og sort footer rows vil du sannsynligvis ikke bruke. Dreamweaver setter 
ikke inn taggene <thead> og <tfoot>. Beholde radenes farger etter en sort vil du sannsynligvs 
heller ikke hvis du har valgt et visst fargesystem på forhånd.  
 

CSS tabellformatering 
Det meste av formatering fra Properties inspector vil validere med DTD for XHTML 
transitional, men med css er det mulig å få til finere kantelinjer og bedre styring med padding 
blant annet. 
 
Vi kan bruke float properties for å få elementer til å flyte rundt tabeller akkurat som rundt 
bilder og div-tagger. Vi kan styre innhold i celler med text-align: left, right, center eller 
justify horisontalt, og vertikalt med vertical-align: baseline, top, bottom eller middle.  
 

Noen vanlige css-regler for tabeller:  
• For rutenett rundt celler: th, td {border: black solid 1px;}  
• For å unngå dobbeltstreker: table {border-collapse: collapse;}  
• For luft mellom innhold og cellevegger: th, td {padding: 0.2em;}  
• For justering av overskriftscelle: th {text-align: left;}  
• For litt farger på overskriftscelle: th {color: white; background-color: green;}  
• For midtstilling av tabell: table {margin-left: auto; margin-right: auto;} 
• For bredde på tabellen: table {width: 500px;} 
• For å få innholdet til toppen av celler: td {vertical-align: top;} 
• For å style en caption: caption {font-size:1.5em; padding-bottom: 0.4em;} 
• Lag classestil for fargelegging av alternative rader etc 
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Oppgave: Layout med tabell 
Justering av høyde og bredde på tabellrader, kolonner og celler gjør det mulig å plassere tekst 
og bilder sammen til sider som er lese- og utskriftsvennlige. For fremtiden brukes ikke 
tabeller til layout, men mange sider er fortsatt designet på denne måten, så derfor en liten 
oppgave her. (Filer til oppgaven finner du på kurswebben.) 
 

1. Kopier bodycopy.txt fra kurswebben og kopier inn i et nytt html-dokument som 
lagres som bodycopy.html. Klikk F12 for å se teksten uten tabellformatering 

2. Gå tilbake til Dreamwever og lag et nytt dokument og lagre som align.html 
3. Sett tittel: "Alignment with tables" 
4. Sett inn bakgrunnsbilde about_bg.jpg og color: #CDCB9A med intern css kode 

 
body { 
 background-image: url(about_bg.jpg); 
 background-repeat: no-repeat; 
 background-color: #cdcb9a; 
} 

5. Insert > Table og velg Rows: 2, Columns: 3, Width: 700 pixels, Border: 0, 
Cellpadding: 2 og Cellspacing: 2. Det skal ikke være Header celler. Klikk OK 

6. Åpne bodycopy.html 
7. Merk og kopier bare adresseinformasjonen øverst til høyre i dokumentet 
8. Velg align.html. Klikk inne i kolonne 2, rad 1 og lim inn adresseteksten 
9. Gå tilbake til bodycopy.html. Merk og kopier første avsnitt og gå tilbake til 

align.html. Lim inn i kolonne 2, rad 2 
10. Gå tilbake til bodycopy.html og merk det andre avsnittet og lim inn i align.html 

kolonne 3, rad 2 
 

 
 

11. Vi må justere teksten i rad 2. Klikk hvor som helst i rad 2. Velg tr i tag selector 
nederst i skjermen. I Property Inspector Vert setting velg Top 

12. Velg View > Rulers > Show eventuelt som en hjelp til å se sidens pixel-fordeling 
13. Plasser musepekeren i adressecellen og klikk Shift +Tab for å gå til cellen til venstre 

Insert > Image, Browse til shim.gif, klikk Open 
I Property Inspector sett shim.gif til 200 pixler. Hvis ikke shim.gif er merket, så klikk 
img i tag selector. Det transparente bildet vil holde kolonnen åpen i passe størrelse 

14. Lagre og klikk F12.  
Siden begynner å ta form, men det er kanskje litt lite luft mellom tekst-cellene? 

15. Gå tilbake til Dreamweaver, stå i tabellen og klikk table i tag selector og sett 
cellspacing til 10 i Property Inspector.  
Lagre og klikk F12. 
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Forms – skjema 
Skjemaer gjør nettsteder interaktive. Vi kan spørre om informasjon, motta bestillinger og 
kommentarer mm. Skjemaer for web har en HTML-del: skjemafeltene, og en script-del: 
programmet på webserveren som behandler input, skjemasvarene. I  Dreamweaver lager vi 
HTML-delen og refererer til scriptet på serveren. Vi kan foreta en validering av skjemafeltene 
i Dreamweaver slik at det blir gitt beskjed om feilutfylte felt etc. Skjemaene inneholder: 
 

• Form tags som inkluderer URL til scriptet som prosesserer skjemaet 
• Form fields, skjemafelt, av forskjellige typer 
• Send knapp som sender data til scriptet på serveren 

 
<form  name="skjemanavn" method=”post” action=”skjemasvar.php”> 

…….. 
</form> 
 
 Følgende tagger settes innenfor FORM taggene for å lage de forskjellige typene skjemafelt: 
 

<input>, <select> og <textarea> 
 

INPUT taggen er “empty” og avsluttes med mellomrom og />, brukes til tekstbokser, 
avkryssningsbokser, radioknapper, send og nullstill-knapper. SELECT taggen er en 
“container” tag og brukes til nedtrekkslister. TEXTAREA brukes til kommentarbokser du kan 
skrive lengre meldinger i. 
 
INPUT har en attributt TYPE og en verdi for å angi hva slags skjemafelt det skal være 
”radio”, ”text”, ”checkbox”, ”submit”, ”reset”. Skjemafeltene har også navn slik at vi lett ser 
hvilket felt som er fylt ut når vi får svarene fra skjema.  
 

<input  type=”felttype” name=”feltnavn” size=”bredde” value=”tekst som står i 
boksen eventuelt” maxlength=”max antall tegn tillatt” /> 

 
Eksempel: <input type=”text” name=”epostadresse” size=”40” / > 
 

Attributten VALUE brukes for å sette tekst på skjemaknappene send og reset slik at de får 
den teksten vi vil, f eks: ”Send skjema” og ”Tøm skjema”. 
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Skjemaside - et eksempel 
 
Et enkelt skjema med tekstskjemafelt kan se ut som følger: 
 
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
<html xmlns="http://www.w3.org/1999/xhtml"> 
<head><title>Enkelt skjema</title></head> 
<body> 
<h1>Enkelt skjema</h1> 
<form method=”post” action=”http://hoohoo.ncsa.uiuc.edu/htbin-post/post-query”> 
Skriv ditt navn her: <input type=”text” name=”navn” size=”40” /><br /> 
Skriv din epost her: <input type=”text” name=”epost” size=”40” />< br /> 
<input type=”submit” value=”Send skjema” /> 
<input type=”reset” value=”Tøm skjema” /> 
</form> 
</body> 
</html> 
 

Forms - skjema med Dreamweaver 
 

1. Menylinjen Insert > Form  
2. eller Insert panelgruppen > velg katagorien Forms > velg Form 

En stiplet rød linje markerer skjemaområdet: Hvis ikke den røde, stiplede linjen synes, 
velg View > Visual Aids > Invisible Elements  

3. Merk skjemaet og gi det et navn i Property inspector  
4. Angi adressen til scriptet i Action feltet og velg Post under Method  
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Sett inn skjemafelt 
 

1. Velg skjemafelt fra meny eller panel. Dra eventuelt skjemafeltikonet inn på siden 
2. Skriv en fortekst, Label, og foreta valg fra "Input Tag Accessibility Attributes" 

dialogboksen: 
3. Valget Wrap with label tag setter <label> taggen rundt både forteksten og selve 

skjemafeltet. Det holder fortekst og skjemefelt sammen  
4. Valget Attach label tag using 'for' attribute pakker teksten i <label>-taggen, men 

plasserer skjemafeltet utenfor <label>-taggen 
<label for="textfield">Name: </label> 
<input type="text" name="textfield" id="textfield" /> 
 
Du vil sannsynligvis forandre textfield til "name" f eks. Da må man manuelt rette i 
koden slik at label viser til riktig skjemafeltnavn: <label for="name">Name: </label> 
 

5. Dropp hele label med valget No label tag  
6. Velg om teksten skal være før eller etter skjemafeltet med posisjonsvalgene Before og 

After, Access key og Tab Index muliggjør bruk av tastaturet for valg av skjemafelt 
(Alt+bokstav) for Windows og (Ctrl+bokstav) for Mac. Tabindex for rekkefølgen av 
skjemafelt velges på  

 

 
 
Å sende skjema-informasjonen til server og database er mer enn HTML alene kan gjøre. Det 
må scripting til. Det er sannsynlig at din web administrator eller Internett-tjenestetilbyder har 
et script du kan bruke. Da er det bare å føre opp URLen til scriptet i skjemaet. 
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Demo: Forms accessible – layout med tabell 
 
 

 
 
 

Text Fields og Textareas 
 

1. Åpne filen contactus.html 
2. Velg Forms gruppen på Insert verktøylinjen 
3. Plasser musepeker under "Tell us all about you" og klikk Form ikonet i Insert 

verktøylinjen 
4. Insert > Table > 8 rader, 2 kolonner, 600px, 4 padding, 0 spacing og border 
5. Plasser musepeker i øverste høyre celle og klikk Text Field knapp på Insert bar 
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6. I Input Tag Accessibility Attributes dialogboks: Label field: Name og velg "Attach 
label tag using for attribute" i Style seksjonen. La alt ellers være standard. OK 
 
 

 
 
 

7. Merk tekstfeltet i Design View og sett navnet CustomerName i Properties 
8. I Properties sto det fra før "textfield" som navn på skjemafeltet. Vi forandrer det ved å 

sette et mer meningsfult navn, men da blir ikke automatisk label forandret samtidig. 
Det må gjøres manuelt i koden. Bruk Quick tag editor og skriv CustomerName: 
<label for= "CustomerName">Name: </label> 

9. Tips: Vi må sørge for at skjemfeltnavn og label navn henger sammen selv om vi 
flytter rundt på felter. Derfor går vi til Edit > Preferences > Code Rewriting > fjern 
avkryssing ved valget: Rename form items when pasting > OK 

10. Nå kan vi dra Name over til venstre celle 
11. Plasser musepekeren i høyre celle i rad nr 2, klikk Text Field knapp, skriv Email 

Address i label og la alt være som før, OK 
12. Sett EmailAddress som skjemafeltnavn i Properties 
13. Sett for attributten til label EmailAddress med Quick Tag editor igjen. 
14. Klikk label i tagvelger på forhånd 
15. Merk og dra forteksten til venstre kolonne 
16. I tredje rad til høyre > klikk Textarea 
17. Skriv Comments i label feltet > OK 
18. I Properties gi skjemafeltet navn Comments > sett 5 i Num Lines feltet 
19. Forandre for attributten for textarea label til Comments igjen. 
20. Dra forteksten til venstre kolonne 
21. Merk venstre kolonne og velg right i Properties slik at fortekstene blir høyrejusterte. 
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Check Boxes og Radio Buttons 
 

1. I fjerde rad i høyre kolonne > klikk Checkbox i Insert bar 
2. Skriv "Add me to the Teacloud newsletter" i label feltet 
3. Velg Wrap with label tag for Style > OK 

Her skal label være After form item og i samme høyre kolonne 
4. Sett skjemfeltnavn i Properties > Newsletter. Skriv Yes i Checked value feltet og la 

Initial state være Unchecked. 
5. Plasser musepekeren i femte rad i høyre kolonne og klikk Radio Group knappen på 

Insert bar 
6. I Radio Group dialogboksen, skriv Referral i Name feltet 

 

 
 
 

7. Klikk første radio knapp label og skriv Newspaper Ad og skriv Newspaper Ad også 
som value. Skriv Friend begge steder for andre radioknapp. Klikk + og skriv Other 
begge steder. La det være "lay out using Line breaks (<br> tags), OK 

8. Merk første radioknapp og velg Checked som Initial state i Properties. 
 

Lists og Menus 
1. Plasser musepekeren i raden under radioknappene 
2. Klikk List/Menu knappen på Insert bar 
3. Skriv "Your favorate tea" i label feltet og velg "Attach label tag using for 

attribute" 
4. I Properties merk select i Design View og gi skjemafeltet navnet FavoriteTea 

Menu valget for vanlig nedtrekksmeny, rullegardinmeny 
5. I Properties, klikk List Values. Skriv inn: Black Tea, Green Tea, Rosehip Tea for label 

og value, klikk OK 
6. Forandre for attributten for label til FavoriteTea og flytt forteksten til venstre kolonne 

Tips: Du kan velge å sette en forklaring i initially selected i Properties. Denne gang er 
ikke det nødvendig. 

7. I neste rad, klikk List/Menu igjen 
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8. Label "Select your favorite stores" og sørg for at Style er satt til "Attach label tag 
using for attribute" 

9. I Properties gi feltnavn FavoriteStores. Sett type til List. Skriv 5 f eks i height feltet 
og velg Allow multiple check boksen 

10. I Properties klikk List Values og skriv inn locations, det samme for label og value: 
Anaheim, Beverly Hills; Brea, Ojai, Pasadene, Pomona, Venice. 

11. Sett for atributten for label til FavoriteStores og flytt forteksten til venstre kolonne. 
12. Shift+Enter for et linjeshift etter List menyen. Skriv en forklaring for bruken av listen: 

"Hold down the Ctrl and click to select multiple stores". 
 

Submitting Form Results 
1. Plasser musepekeren i neste rad, celle til høyre.  
2. Klikk Button på Insert bar 
3. Klikk Cancel for å lukke Accessibility Attributes dialogboksen 
4. Med button merket, skriv Contact Us i Value feltet i properties 
5. Klikk Button på Insert bar igjen. Lag en Reset knapp, skriv Clear i Value feltet 
6. I Tag Selector merk <form#form1>. Gi skjemaet navn TeaContact. 

 

 
 
 

CSS styling 
Dokumentet contactus.htm har et innlenket stilark. Vi kan føye til stilregler for skjemafeltene 
hvis vi ønsker det; enten i det eksterne stilarket eller som ekstra embedded, internt, stilark. For 
eksempel kunne det være fint å få teksten i nedtrekksmenyene til å være mer lik øvrig tekst. 
Send og Reset knappene kan også styles litt kanskje. Forslag: 
 
 

select { 
 font-family: Georgia, "Times New Roman", Times, serif; 
 font-size: 0.9em; 
 color: #666; 
} 
.button { 
 font-family: Georgia, "Times New Roman", Times, serif; 
 font-size: 0.9em; 
 color: #060; 
} 
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Validate Forms 
1. Sett musepekeren i skjemaet, klikk om nødvendig <form> taggen i tagvelger nederst i 

dokumentvinduet 
2. Velg Window > Behaviors 
3. Velg Validate Form  
4. Velg felter og sett tillatte valg for feltene etter tur 

(Flere felt vises her hvis du har satt inn flere felt i skjemaet) 
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Skjema med CSS 

 

HTML 
<form id="kontakt" name="kontakt" method="post" action=""> 
 <fieldset>   
<legend>Påmelding</legend> 
 <p>Felter markert med <em>*</em> er obligatoriske.</p> 
 <label for="navn">Navn: <em>*</em></label> <br /> 
 <input name="navn" type="text" id="navn" /><br /> 
<label for="adresse">Adresse: </label><br /> 
 <input name="adresse" type="text" id="adresse" /><br /> 
<label for="epost">E-post: <em>*</em></label><br /> 
<input name="epost" type="text" id="epost" /><br /> 
<label for="ferdighet">Ditt nivå: </label><br /> 
<textarea name="ferdighet" id="ferdighet" cols="45" rows="5"></textarea> 
<p> 
<label for="sted">Hvor vil du ta kurset?</label> 
<select name="sted" id="sted"> 
<option value="hemsedal">Hemsedal</option> 
 <option value="geilo">Geilo</option> 
 <option value="oppdal">Oppdal</option> 
 </select> 
 </p> 
 <p> 
<label for="button"></label> 
<input type="submit" name="button" id="button" value="Send påmelding" /> 
<label for="button2"></label> 
<input type="reset" name="button2" id="button2" value="Tøm skjema" /> 
 </p></fieldset>  </form> 
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CSS 
fieldset { 
 border: 2px solid #495478; 
 width: 30em; 
 padding-top: 0.8em; 
 padding-right: 0; 
 padding-bottom: 0.8em; 
 padding-left: 0.8em; 
} 
legend { 
 font-size: 1.5em; 
 color: #272E42; 
 font-weight: bold; 
} 
input, textarea { 
 width: 24em; 
 border: 1px solid #4A567B; 
} 
select { 
 width: 10em; 
 margin-left: 0.6em; 
} 
form em { 
 font-weight: bold; 
 color: #cc0000; 
} 
#send { 
 width: 10em; 
} 
#nullstill { 
 width: 10em; 
 margin-left: 0.5em; 
} 
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